error in installing 'composer require nao-pon/flysystem-google-drive:~1.1'

· · 191 views

the error is:

[[ Fatal error: Allowed memory size of 1610612736 bytes exhausted (tried to allocate 41943040 bytes) in phar:///usr/local/bin/composer1.phar/src/Composer/DependencyResolver/RuleSet.php on line 90

Check https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors for more info on how to handle out of memory errors.[[email protected] public_html] ]]

when using this command this is error:

'COMPOSER_MEMORY_LIMIT=-1 composer require nao-pon/flysystem-google-drive:~1.1'

[[

Your requirements could not be resolved to an installable set of packages.

Problem 1 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.13 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.12 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.11 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.10 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.9 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.8 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.7 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.6 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.5 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.4 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.3 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.2 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.1 - Conclusion: don't install nao-pon/flysystem-google-drive 1.1.0 - Conclusion: remove league/flysystem 3.10.2 - Installation request for nao-pon/flysystem-google-drive ~1.1 -> satisfiable by nao-pon/flysystem-google-drive[1.1.0, 1.1.1, 1.1.10, 1.1.11, 1.1.12, 1.1.13, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.1.9, 1.1.x-dev]. - Conclusion: don't install league/flysystem 3.10.2 - nao-pon/flysystem-google-drive 1.1.x-dev requires league/flysystem ~1.0 -> satisfiable by league/flysystem[1.0.0, 1.0.0-alpha1, 1.0.1, 1.0.10, 1.0.11, 1.0.12, 1.0.13, 1.0.14, 1.0.15, 1.0.16, 1.0.17, 1.0.18, 1.0.19, 1.0.2, 1.0.20, 1.0.21, 1.0.22, 1.0.23, 1.0.24, 1.0.25, 1.0.26, 1.0.27, 1.0.28, 1.0.29, 1.0.3, 1.0.30, 1.0.31, 1.0.32, 1.0.33, 1.0.34, 1.0.35, 1.0.36, 1.0.37, 1.0.38, 1.0.39, 1.0.4, 1.0.40, 1.0.41, 1.0.42, 1.0.43, 1.0.44, 1.0.45, 1.0.46, 1.0.47, 1.0.48, 1.0.49, 1.0.5, 1.0.50, 1.0.51, 1.0.52, 1.0.53, 1.0.54, 1.0.55, 1.0.56, 1.0.57, 1.0.58, 1.0.59, 1.0.6, 1.0.60, 1.0.61, 1.0.62, 1.0.63, 1.0.64, 1.0.65, 1.0.66, 1.0.67, 1.0.68, 1.0.69, 1.0.7, 1.0.70, 1.0.8, 1.0.9, 1.0.x-dev, 1.1.0, 1.1.1, 1.1.10, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.1.9, 1.x-dev]. - Can only install one of: league/flysystem[1.0.0, 3.10.2]. - Can only install one of: league/flysystem[1.0.0-alpha1, 3.10.2]. - Can only install one of: league/flysystem[1.0.1, 3.10.2]. - Can only install one of: league/flysystem[1.0.10, 3.10.2]. - Can only install one of: league/flysystem[1.0.11, 3.10.2]. - Can only install one of: league/flysystem[1.0.12, 3.10.2]. - Can only install one of: league/flysystem[1.0.13, 3.10.2]. - Can only install one of: league/flysystem[1.0.14, 3.10.2]. - Can only install one of: league/flysystem[1.0.15, 3.10.2]. - Can only install one of: league/flysystem[1.0.16, 3.10.2]. - Can only install one of: league/flysystem[1.0.17, 3.10.2]. - Can only install one of: league/flysystem[1.0.18, 3.10.2]. - Can only install one of: league/flysystem[1.0.19, 3.10.2]. - Can only install one of: league/flysystem[1.0.2, 3.10.2]. - Can only install one of: league/flysystem[1.0.20, 3.10.2]. - Can only install one of: league/flysystem[1.0.21, 3.10.2]. - Can only install one of: league/flysystem[1.0.22, 3.10.2]. - Can only install one of: league/flysystem[1.0.23, 3.10.2]. - Can only install one of: league/flysystem[1.0.24, 3.10.2]. - Can only install one of: league/flysystem[1.0.25, 3.10.2]. - Can only install one of: league/flysystem[1.0.26, 3.10.2]. - Can only install one of: league/flysystem[1.0.27, 3.10.2]. - Can only install one of: league/flysystem[1.0.28, 3.10.2]. - Can only install one of: league/flysystem[1.0.29, 3.10.2]. - Can only install one of: league/flysystem[1.0.3, 3.10.2]. - Can only install one of: league/flysystem[1.0.30, 3.10.2]. - Can only install one of: league/flysystem[1.0.31, 3.10.2]. - Can only install one of: league/flysystem[1.0.32, 3.10.2]. - Can only install one of: league/flysystem[1.0.33, 3.10.2]. - Can only install one of: league/flysystem[1.0.34, 3.10.2]. - Can only install one of: league/flysystem[1.0.35, 3.10.2]. - Can only install one of: league/flysystem[1.0.36, 3.10.2]. - Can only install one of: league/flysystem[1.0.37, 3.10.2]. - Can only install one of: league/flysystem[1.0.38, 3.10.2]. - Can only install one of: league/flysystem[1.0.39, 3.10.2]. - Can only install one of: league/flysystem[1.0.4, 3.10.2]. - Can only install one of: league/flysystem[1.0.40, 3.10.2]. - Can only install one of: league/flysystem[1.0.41, 3.10.2]. - Can only install one of: league/flysystem[1.0.42, 3.10.2]. - Can only install one of: league/flysystem[1.0.43, 3.10.2]. - Can only install one of: league/flysystem[1.0.44, 3.10.2]. - Can only install one of: league/flysystem[1.0.45, 3.10.2]. - Can only install one of: league/flysystem[1.0.46, 3.10.2]. - Can only install one of: league/flysystem[1.0.47, 3.10.2]. - Can only install one of: league/flysystem[1.0.48, 3.10.2]. - Can only install one of: league/flysystem[1.0.49, 3.10.2]. - Can only install one of: league/flysystem[1.0.5, 3.10.2]. - Can only install one of: league/flysystem[1.0.50, 3.10.2]. - Can only install one of: league/flysystem[1.0.51, 3.10.2]. - Can only install one of: league/flysystem[1.0.52, 3.10.2]. - Can only install one of: league/flysystem[1.0.53, 3.10.2]. - Can only install one of: league/flysystem[1.0.54, 3.10.2]. - Can only install one of: league/flysystem[1.0.55, 3.10.2]. - Can only install one of: league/flysystem[1.0.56, 3.10.2]. - Can only install one of: league/flysystem[1.0.57, 3.10.2]. - Can only install one of: league/flysystem[1.0.58, 3.10.2]. - Can only install one of: league/flysystem[1.0.59, 3.10.2]. - Can only install one of: league/flysystem[1.0.6, 3.10.2]. - Can only install one of: league/flysystem[1.0.60, 3.10.2]. - Can only install one of: league/flysystem[1.0.61, 3.10.2]. - Can only install one of: league/flysystem[1.0.62, 3.10.2]. - Can only install one of: league/flysystem[1.0.63, 3.10.2]. - Can only install one of: league/flysystem[1.0.64, 3.10.2]. - Can only install one of: league/flysystem[1.0.65, 3.10.2]. - Can only install one of: league/flysystem[1.0.66, 3.10.2]. - Can only install one of: league/flysystem[1.0.67, 3.10.2]. - Can only install one of: league/flysystem[1.0.68, 3.10.2]. - Can only install one of: league/flysystem[1.0.69, 3.10.2]. - Can only install one of: league/flysystem[1.0.7, 3.10.2]. - Can only install one of: league/flysystem[1.0.70, 3.10.2]. - Can only install one of: league/flysystem[1.0.8, 3.10.2]. - Can only install one of: league/flysystem[1.0.9, 3.10.2]. - Can only install one of: league/flysystem[1.0.x-dev, 3.10.2]. - Can only install one of: league/flysystem[1.1.0, 3.10.2]. - Can only install one of: league/flysystem[1.1.1, 3.10.2]. - Can only install one of: league/flysystem[1.1.10, 3.10.2]. - Can only install one of: league/flysystem[1.1.2, 3.10.2]. - Can only install one of: league/flysystem[1.1.3, 3.10.2]. - Can only install one of: league/flysystem[1.1.4, 3.10.2]. - Can only install one of: league/flysystem[1.1.5, 3.10.2]. - Can only install one of: league/flysystem[1.1.6, 3.10.2]. - Can only install one of: league/flysystem[1.1.7, 3.10.2]. - Can only install one of: league/flysystem[1.1.8, 3.10.2]. - Can only install one of: league/flysystem[1.1.9, 3.10.2]. - Can only install one of: league/flysystem[1.x-dev, 3.10.2]. - Installation request for league/flysystem (locked at 3.10.2) -> satisfiable by league/flysystem[3.10.2].

Installation failed, reverting ./composer.json to its original content.

]] in server host hostinger (server have 1GB RAM)

0
1 Answer

This error is because you have low RAM. The second thing is nao-pon/flysystem-google-drive is not updated for nearly 2 years. And It depends on an old version of league/flysystem. So, you also need to check if your application may depend on the latest version of league/flysystem.

0

Please login or create new account to participate in this conversation.