How to enable Ubuntu microphone noise cancellation and fix volume auto adjusted issue?


Is it possible to do realtime noise-removal with PulseAudio? And I also want to fix volume auto adjusted. The microphone started at 100% and slowly started to drop. This is because of either a background noise or the user raising their voice.

1 Answer

I have also faced the same issue. After so much search, I found this solution. It might be helpful for you as well. So try this:

Edit /etc/pulse/

sudo vi /etc/pulse/

Now add the following lines at the end of the file.

### Enable Echo/Noise-Cancelation
load-module module-echo-cancel aec_args="analog_gain_control=0 digital_gain_control=1" source_name=echoCancel_source sink_name=echoCancel_sink source_properties=device.description=CancelEcho
set-default-source echoCancel_source
set-default-sink echoCancel_sink

then restart Pulseaudio

pulseaudio -k
pulseaudio --start

Now you should be able to select the new Noise Cancellation option from the Input Device Section.


Please login or create new account to participate in this conversation.